开发软件

Mr.Hope ... 2019-11-21 Linux 小于 1 分钟

# 开发软件

# 安装 VS Code

  • 使用 snap

    sudo snap install --classic code
    
    1
  • 在 WSL 环境下 snap 无法使用,则使用以下命令安装 code 库。

    curl https://packages.microsoft.com/keys/microsoft.asc | gpg --dearmor > packages.microsoft.gpg
    sudo install -o root -g root -m 644 packages.microsoft.gpg /usr/share/keyrings/
    sudo sh -c 'echo "deb [arch=amd64 signed-by=/usr/share/keyrings/packages.microsoft.gpg] https://packages.microsoft.com/repos/vscode stable main" > /etc/apt/sources.list.d/vscode.list'
    
    1
    2
    3

    然后正常安装:

    sudo apt-get install apt-transport-https
    sudo apt-get update
    sudo apt-get install code # or code-insiders
    
    1
    2
    3

可能还需要安装

sudo apt-get install libx11-xcb1 libasound2
1

# remote 插件安装

code --install-extension ms-vscode-remote.vscode-remote-extensionpack
1

# nvm

curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.35.1/install.sh | bash
1

在 Linux 上可能需要重新链接终端,命令才可用。

测试命令,输入 nvm 即安装成功:

command -v nvm
1

安装命令:

nvm install 10
1

切换命令:

nvm use 10
1

# 安装 Git

sudo add-apt-repository ppa:git-core/ppa

sudo apt-get update

sudo apt-get install git
1
2
3
4
5

# yarn

curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
sudo apt-get update && sudo apt-get install yarn
1
2
3

测试是否安装成功:

yarn --version
1